Debian Weekly News #31 — August 1st, 2006

歡迎閱讀本年度第三十一期的 DWN,每週 Debian 社群周報Debian 社群快訊。 Christoph Berg
宣佈有九個新的
QA 成員正在處理影響 etch
釋出的顯著問題。Gintautas Miliauskas
報告
他正在進行一個基於 WordForge
計畫,給 Debian 用的完整 l10n 基礎建設。

【使用合適的「急切程度」】 Adeodato Simó
提醒
開發人員,欲上載的更新套件若為安全性修正,應該將急切程度設為 high。而
medium 程度則是用在修正影響發行的問題,包含解決那種在某些平台上無法正確編譯的情況。這些套件在 unstable 中等待進入
testing
的時間會比較短,因此在處理時也該特別用點心思。

【套件的所有權】 Martin Krafft 提出這樣的議題:Debian
的套件維護者是不是能接受和他人合作維護套件?Adeodato Simó 認為,在接受非該套件維護人員提供的修補(non-maintainer
diff)前,若能讓它待在臭蟲追蹤系統中一些時日,對品質確保(QA)會有一定的幫助,因為這讓其他人能有機會幫忙檢視該修補的正確性。

【在 Debian GNU/Linux 3.1 上安裝 Xen】 Aike de
Jongste 的一篇文章說明如何在一個
stable Debian
系統上安裝 backported 版的
Xen。所需的步驟包括了使用 APT
pinning
安裝一些套件,製作一個特別的 RAM disk,在 grub 的開機選單中加上新的項目,以及建立 Xen
虛擬機器。

【讓衍生產品可以得到 Debian 名號的加持】 Anthony Towns 提議建立官方對衍生
distributions 的授權方式,讓這些衍生產品可以享受 Debian
信譽帶來的好處。當然,想要享有這些好處,這些衍生產品必須願意傾聽來自使用者的意見,並且和自由軟體社群保持良好合作關係。相對的,Debian
應該提供一個 logo,在網頁上加上該衍生產品的連結,協助發佈消息,以及建立未來合作和諮詢的準則。

【管理 Secure APT 的鑰匙】 Joey Schulze 好奇金鑰管理功能是否能在
etch 釋出前即時加入
APT中。Martin Krafft
反對僅僅只有自動更新金鑰,因為這實在太脆弱而易遭到攻擊。他較喜歡有第三方來替金鑰簽章。Florian
Weimer 指出現在已知可行的辦法是給
stable releases 和 stable 安全更新使用不會改變的金鑰。

【在 Etch 中支援 Exim 3?】 Marc Haber 列出
Exim version 3 從
etch
中移除所需的步驟,因為現在不但 Exim 官方不再對此版本提供支援,就連套件維護者都已停止使用該套件。我們必須提供 sarge 的更新套件,而且,當使用者從
sarge 更新至 etch 時需要手動修改設定。

【產生程式的說明文件】 Marcio Roberto Teixeira 問道,Debian
套件中的文件檔應該要在編譯套件前就預先處理好,以節省編譯的時間,還是應該在編譯時一起處理。Goswin von Brederlow
表示,文件應該在該套件編譯時一併處理。如果這樣會嚴重影響該套件編譯的時間,那表示要把文件的部份獨立出來,另外包成一個各平台通用的套件,如此就不會在編譯每個平台的套件時一直重覆地處理那些文件。

【安裝 setuid 的程式】 Yui-wah Lee 當一個程式需要
setuid 或是 setgid 時,它的套件該如何製作。Matthew Palmer 表示,此時套件維護人員除了要把檔案的權限設好,還可能要調整
dh_fixperms,以免權限又被改回預設的樣子。使用這些套件的系統管理者則可以用
dpkg-statoverride 來修改檔案的權限。

【套件描述文字的翻譯情況】 Michael Vogt 大家幫忙測試
experimental 中的 APT。這個版本支援本地化的套件描述,這些翻譯過的描述其實在許多
sid 的 mirror
中都已經可以找到,在 Debian 套件描述翻譯計畫
(Debian description translation
project)的網站上也可以取得。供大家參與翻譯的系統尚未完備,例如目前並未支援之前提供的校閱功能,但這些不足的部份都已有要著手進行開發的計畫

【安全更新】您知道該怎麼做。如果您安裝了下列任何套件, 請務必更新系統。

  • DSA 1125: drupal
    Execution of arbitrary web script code.
  • DSA 1126: asterisk
    Denial of service.
  • DSA 1127: ethereal
    Several vulnerabilities.
  • DSA 1128: heartbeat
    Denial of service.
  • DSA 1129: osiris
    Arbitrary code execution.
  • DSA 1130: sitebar
    Cross-site scripting.

【新的或值得注意的軟體套件】 下列套件是最近被加到
unstable Debian 檔案庫或是有重大更新。

  • bcfg2
    Configuration management client.
  • beaglefs
    Implements a filesystem representing a live Beagle query.
  • biloba
    Turn based strategy board game for up to 4 players.
  • byzanz
    Small screencast creator.
  • console-setup-mini
    — Experimental micro version of console-setup package.
  • cryptmount
    — Management and user-mode mounting of encrypted file systems.
  • gshare
    Easy user-level file sharing for GNOME.
  • jpnevulator
    — Serial sniffer.
  • multisync-tools
    — PIM Synchronisation Command Line Tools.
  • necpp
    NEC2 Evolution Antenna Modelling System.
  • open-iscsi
    — High performance, transport independent implementation of
    RFC3720.
  • openser
    Very fast and configurable SIP proxy.
  • p3nfs
    Mount the file systems on the Psion/Symbian PDA/Phone.
  • pdfcrack
    PDF files password cracker.
  • phpgedview
    — Web-based genealogy viewer and editor.
  • qrfcview
    Viewer for IETF RFCs.
  • rant
    Flexible, Ruby based make.
  • serpentine
    — Application for creating audio CDs.
  • splashy
    — Complete user-space boot splash system.
  • tshark
    Network traffic analyser (console).
  • vbindiff
    Visual binary diff, visually compare binary files.
  • wireshark
    Network traffic analyser.
  • wise
    Comparison of biopolymers, commonly DNA and protein sequence.

【孤兒套件】本週又有 7 個套件變成孤兒啦! 他們需要新的維護者照顧。這造成目前總共有 343
個孤兒套件。非常感謝 那些前維護者對於自由軟體社群的貢獻。請閱覽 WNPP
網頁查詢完整的列表。如果你有興趣接手任一個套件的話,請 手加上一個臭蟲報告並把標題改成
ITA。devscripts 套件中的 wnpp-alert
程式可以幫您找出有哪些孤兒套件裝在您系統上。

【被移除的套件】 過去一週內,有 18 個套件被移出 Debian 檔案庫了:

  • openldap2.2 — OpenLDAP utilities
    Bug#340349: Request of
    QA, superseded by openldap2.3; RC-buggy (non-free content)
  • ultrapossum — Multi-functional LDAP Solution
    Bug#378885: Request of
    QA, dead upstream, unmaintained, depends on removed
    openldap2.2
  • installwatch — Track installation of local software
    Bug#347469: Request of
    QA, merged into checkinstall
  • webmin-ldap-netgroups — LDAP webmin module for editing
    netgroups
    Bug#347773: Request of
    maintainer, depends on removed webmin
  • kimberlite — High Availability Clustering Package
    Bug#348195: Request of
    QA, orphaned, unused, dead upstream
  • mozilla-firefox-locale-it — Mozilla Firefox Italian
    Language/Region Package
    Bug#348357: Request of
    maintainer, superseded by mozilla-firefox-locale-all
  • mgapdesk — X configuration tool for Matrox video card
    Bug#364344: Request of
    QA, orphaned, RC-buggy
  • libzlib-ruby — Extension library to use zlib from Ruby 1.6
    Bug#367903: Request of
    maintainer, ruby 1.6 removal
  • libiconv-ruby — Wrapper class of iconv for the Ruby 1.6.x
    Bug#367907: Request of
    maintainer, ruby 1.6 removal
  • libstrscan-ruby — Fast string scanning library for Ruby
    Bug#369417: Request of
    maintainer, ruby 1.6 removal
  • xerces26 — validating XML parser library for C++ (development
    files)
    Bug#375929: Request of
    maintainer, superseded by xerces27
  • gtk-smooth-engine — Smooth Engine for GTK+ 1.2
    Bug#378663: Request of
    maintainer, superseded by gtk2-engines
  • fisg — Fast IRC Statistics Generator
    Bug#378910: Request of
    maintainer, dead upstream
  • parted-swig — Perl5 bindings for libparted
    Bug#379293: Request of
    maintainer, upstream gone; out of date; RC buggy
  • python-orbit — Python bindings for ORBit
    Bug#379436: Request of
    maintainer, obsolete
  • tkpgp — Tcl/Tk script that serves as a GUI shell for PGP or
    GnuPG
    Bug#379509: Request of
    maintainer, upstream gone
  • mindi-kernel — Failsafe Linux kernel for Mindi/Mondo
    Bug#379570: Request of
    maintainer, replaced by using stock Debian kernels; 2.4 only
  • libflorist-3.15p-1 — POSIX.5 Ada interface to operating system
    services
    Bug#379795: Request of
    maintainer, superseded by libflorist, RC-buggy

【想繼續閱讀 DWN 嗎?】 請幫助我們製作這份新聞。 我們需要更多的自願作家盯著
Debian 社群,為我們報導社群中的動態。請見 投稿網頁瞭解
如何幫助我們。我們的信箱 dwn@debian.org
期待著您的來信!


已發佈

分類:

,

作者:

標籤: